
Module 2a: Basic Sketching I 
In this tutorial, you will draw the sketch of the model shown in Figure 1. The sketch is shown 
in Figure 2. You will not dimension the sketch. The solid model and the dimensions are given 
only for your reference.  

 
 Figure 1 Solid model   Figure 2 Sketch for the solid model 
The steps that will be followed to complete this tutorial are listed below:  

1. Start SolidWorks and then start a new part document.  

2. Maximize the part file document and then switch to the sketching environment.  

3. Draw the sketch of the model using the Line and the Circle tools, refer to Figures 4 
through 7.  

4. Save the sketch and then close the document.  

Starting SolidWorks and Starting a New Part Document  

1. Start SolidWorks by choosing Start> Programs> SolidWorks 2005 > SolidWorks 

2005 or by double-clicking the shortcut icon  of SolidWorks available on the 
desktop of your computer.  

2. The SolidWorks 2005 window is displayed. Choose the New Document option from 
this window. The New SolidWorks Document dialog box is displayed.  

3. The Part button is chosen by default. Choose the OK button from the New 
SolidWorks Document dialog box as shown in Figure 3. A new SolidWorks part 
document will be opened. But the part document window will not be maximized in 
the SolidWorks window.  
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Figure 3 New SolidWorks document dialog box. 

4. Choose the Maximize  button available on the upper right corner of the part 
document window to maximize the document window. When you open a new part 
document, the part modeling environment is active by default. As you first need to 
draw the sketch of the feature, you need to invoke the sketching environment.  

5. Select the Front plane.  

6. Choose the Sketch  button from the Standard toolbar. The Sketch tools toolbar 
becomes highlighted. The sketching environment is invoked and the plane is oriented 
normal to the view i.e., parallel to screen. You will notice that a red color origin is 
displayed in the center of the screen, indicating the sketching environment. The 
default screen appearance of the sketching environment of SolidWorks is shown in 
Figure 4.  
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Figure 4 Starting a new sketch. 

Setting the Units and Grid  

1. Choose Tools> Options from the menu bar to invoke the System Options -General 
dialog box.  

2. Choose the Document Properties tab. The name of the dialog box is changed to the 
Document Properties -Detailing dialog box.  

3. Select the Units option from the area on the left to display the options related to linear 
and angular units.  

4. Select millimeters from the drop-down list available in the Length units area. Also, 
select the Degrees option from the drop-down list provided in the Angular units area.  

5. Select Grid/Snap from the area on the left. Set the value of the Major grid spacing 
spinner to 100 and the value of the Minor-lines per major spinner to 10.  

6. Select the Go to System Snaps, check Grid box in the Sketch Snap area, if it is 
cleared. Choose OK to exit the dialog box.  

Drawing the Outer Loop of the Sketch  
It is a good practice to draw the sketch on one side of the origin, preferably in the first 
quadrant. This is because while generating the part program for manufacturing the part, you 
will have a reference for work origin in advance.  

The sketch of the model consists of an outer loop, two circles inside the outer loop, and a 
cavity. Therefore, it will be drawn using the Line and the Circle tools. You will first draw the 
outer loop and then the inner entities. Note that in the sketcher environment, the lower right 
corner of the SolidWorks window displays three areas. The first area displays the X, Y, and Z 
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coordinates of the current location of the cursor. These coordinates will be modified as you 
move the cursor around the drawing area. You will use the coordinate display to draw the 
sketch of the model.  

You will start drawing the sketch from the lower left corner of the sketch and the outer; loop 
will be drawn using the continuous lines.  

1. Click Line  button on the Sketch toolbar to invoke the Line tool. The arrow cursor 
will be replaced by the line cursor.  

2. Move the cursor in the first quadrant close to the origin. The coordinates of the point 
are displayed close to the lower right corner of the screen.  

3. Press the left mouse button at the point whose coordinates are 10 mm 10 mm 0 mm 
and then move the cursor horizontally toward the right.  

You will notice that the symbol of Horizontal relation is displayed below the line 
cursor and the length of the line is displayed above the line cursor. As the length of 
the first horizontal line at the lower left comer is 10 mm, you will move the mouse 
until the length of the line is shown as 10 above the line cursor.  

4. Press the left mouse button when the length of the line that is displayed above the line 
cursor shows a value of 10.  

The first horizontal line is drawn. Because you are drawing continuous lines, the 
endpoint of the last line is automatically selected as the start point of the next line.  

5. Move the line cursor vertically upward. The symbol of Vertical relation is displayed 
below the line cursor and the length of the line is displayed above the line cursor.  

6. Press the left mouse button when the length of the line displayed above the line cursor 
shows a value of 10.  

A vertical line of length 10 mm will be drawn and will be displayed in green color. 
Also, as this is the line that is selected now, the previous line will no more be 
highlighted and therefore will be displayed in blue color.  

7. Move the line cursor horizontally toward the right. Press the left mouse button when 
the length of the line above the line cursor shows a value of 10. This draws the next 
horizontal line of 10 mm length.  

8. Move the line cursor vertically downward and press the left mouse button when the 
length of the line on the line cursor shows a value of 10.  

9. Move the line cursor horizontally toward the right and press the left mouse button 
when the length of the line on the line cursor shows a value of 30.  

10. Move the line cursor vertically upward and press the left mouse button when the 
length of the line on the line cursor shows a value of 10.  

11. Move the line cursor horizontally toward the right and press the left mouse button 
when the length of the line on the line cursor shows a value of 10.  

12. Move the line cursor vertically downward and press the left mouse button when the 
length of the line on the cursor shows a value of 10.  

13. Move the line cursor horizontally toward the right and press the left mouse button 
when the length of the line on the line cursor shows a value of 10. 
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14. Move the line cursor vertically upward and press the left mouse button when the 
length of the line on the line cursor displays a value of 40.  

The next line that you will draw is an inclined line that makes an angle of 135°. To 
draw this line, you will move the cursor in a direction that makes an angle of 135°.  

The aligned length of the line is not given for this line. Instead, the delta X and delta 
Y values are given. Therefore, you will draw a line at this point such that the delta X 
and delta Y value of this line is 10 mm each. These values can be viewed in the Line 
Property Manager. The last spinners in the Line PropertyManager are for the delta 
values.  

15. Move the line cursor such that the line is drawn at an angle of 135-degree. The current 
angle will be displayed in the spinner above the delta spinners in the Line 
PropertyManager.  

16. Press the left mouse button when the delta X value in the Delta X spinner shows a 
value of 10 and the value of delta Y in the Delta Y spinner displays a value of 10 in 
the Line Property Manager. At this stage, the length of the line will be displayed as 
14.14 above the line cursor and also in the Length spinner in the Line 
PropertyManager.  

17. Move the line cursor horizontally toward the left and press the left mouse button when 
the length of the line on the line cursor displays a value of 50.  

You will notice that some blue and brown inferencing lines are displayed when you 
move the cursor.  

18. Move the line cursor in the direction of 225-degree angle.  

You will notice that two blue inferencing lines are displayed. The first one originates 
from the start point of the first inclined line and the other one from the start point of 
the first line of the sketch.  

19. Press the left mouse button at the point where the two inferencing lines intersect.  

You will notice that at this point, the length of the line on the line cursor shows a 
value of 14.14. Also, the delta X and delta Y values in the Line Property Manager 
are displayed as 10 each and the angle is shown as 225-degree.  

20. Move the cursor vertically downward to the start point of the first line.  

You will notice that when you move the cursor close to the start point of the first line, 
a red circle is displayed. Also, the line cursor turns yellow in color and an orange-
colored box is displayed below the line cursor. The length of the line shows a value of 
40.  

21. Press the left mouse button when the red circle is displayed. Right-click to display the 
shortcut menu and choose the Select option to exit the Line tool.  

This completes the sketch of the outer loop. Note that the display of the sketch is 
small. Therefore, you need to modify the drawing display area such that the sketch fits 
the screen. This is done using the Zoom to Fit tool.  

22. Choose the Zoom to Fit  button from the View toolbar to fit the current sketch on 
the screen.  
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The outer loop of the sketch is completed and is shown in Figure 5.  

 

Figure 5 Outer loop of the sketch. 

Drawing Circles  
The circles will be drawn using the Circle tool. You will use the inferencing line originating 
from the start points and endpoints of the inclined lines to specify the center point of the 
circles. As mentioned earlier, the cursor in the sketching environment jumps through a 
distance of 10 mm by default. Therefore, when you move the cursor to define the radius of 
the circle, the minimum value that can be set is 10 mm. But the radius of the circle is 5 mm 
and to specify this value, the cursor needs to jump only through a distance of 5 mm. This is 
the reason you need to modify the document settings so that the cursor jumps through a 
distance of 5 mm.  

1. Choose Tools> Options from the menu bar to invoke the System Options -General 
dialog box. Choose the Document Properties tab.  

2. Select the Grid/Snap option from the area on the left to display the options related to 
linear and angular units. Set the value of the Major grid spacing spinner to 50 and 
choose OK.  

Setting this value to 50 will force the cursor to jump through a distance of 5 mm 
instead of 10 mm. Therefore, when you move the cursor now, the values shown on the 
cursor and the coordinates of the points shown close to the lower right corner of the 
SolidWorks window will be in the increment of 5 mm.  

3. Choose the Circle  button from the sketch toolbar to invoke the Circle tool.  

As the Select  tool was active earlier, the cursor earlier was the arrow cursor. But 

when you invoke the Circle  tool, the arrow cursor will be replaced by the circle 
cursor.  

4. Move the circle cursor close to the lower endpoint of the right inclined line and then 
move it toward the left. Remember that you will not press the left mouse button at this 
moment.  

An inferencing line is displayed generating from the lower endpoint of the right 
inclined line. When you move the cursor toward the left, you will notice that at the 
point where the cursor is vertically in line with the upper endpoint of the right inclined 
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line, another inferencing line is generated from the upper endpoint of the right 
inclined line. This inferencing line will intersect the inferencing line generated from 
the lower endpoint of the inclined line.  

5. Press the left mouse button at the point where the inferencing lines from both the 
endpoints of the inclined lines intersect. Now, move the circle cursor toward the left 
to define a circle.  

6. Press the left mouse button when the radius of the circle displayed above the circle 
cursor shows a value of 5.  

7. Similarly, draw the circle on the left using the inferencing lines generating from the 
endpoints of the left inclined line. The sketch after drawing the two circles inside the 
outer loop is shown in Figure 6.  

8. Right-click in the drawing area and choose Select to exit the Circle tool.  

 

Figure 6 Outer loop of the sketch including circles. 

Drawing the Sketch of the Inner Cavity  

Next, you will draw the sketch of the inner cavity. To draw the sketch of the inner cavity, you 
will start drawing with the lower horizontal line.  

1. Choose the Line  button from the Sketch toolbar. The arrow cursor is replaced by 
the line cursor.  

2. Move the line cursor to a location whose coordinates are 30 mm 25 mm 0 mm.  

3. Press the left mouse button at this point and move the cursor horizontally toward the 
right. Press the left mouse button when the length of the line above the line cursor 
shows a value of 30.  

4. Move the line cursor vertically upward and press the left mouse button when the 
length of the line on the line cursor displays a value of 10.  

5. Move the line cursor horizontally toward the left and press the left mouse button when 
the length of the line on the line cursor displays a value of 10.  

6. Move the line cursor vertically downward and press the left mouse button when the 
length of the line on the line cursor displays a value of 5.  

7. Move the line cursor horizontally toward the left and press the left mouse button when 
the length of the line on the line cursor displays a value of 10.  

8. Move the line cursor vertically upward and press the left mouse button when the 
length of the line on the line cursor displays a value of 5.  
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9. Move the line horizontally toward the left and press the left mouse button when the 
length of the line on the line cursor displays a value of 10.  

10. Move the line cursor vertically downward to the start point of the first line. Press the 
left mouse button when the red circle is displayed. The length of the line at this point 
will show a Value of 10.  

11. Right-click and choose Select from the shortcut menu. This completes the sketch for 
this Tutorial. The final completed sketch is shown in Figure 7.  

 

Figure 7 Completed sketch for the model. 

Saving the Sketch and model  

1. Choose the Save  button from the Standard toolbar to invoke the Save As dialog 
box.  

2. Enter the name of the document as tutorial1.sldprt in the File name edit box and 
choose the Save button. The document will be saved in the specified folder. It is 
recommended that you create a separate folder for SolidWorks files. 
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Figure 8  

3. Select Extrude Boss/Base  on the Features toolbar. The profile changes its 
orientation to pictorial. The Extrude Property Manager appears as shown in Figure 8. 

4. In the Depth text box, type 20 mm as shown in Figure 8. Click OK  to finish 
the extruded base feature. 

5. Choose the Save  button from the Standard toolbar to save the model. 

6. Close the document by choosing File> Close from the menu bar.  
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