
Module 1: Basics of Solids Modeling with SolidWorks 
 
Introduction 
SolidWorks is the state of the art in computer-aided design (CAD). SolidWorks 
represents an object in a virtual environment just as it exists in reality, i.e., having volume 
as well as surfaces and edges. This, along with exceptional ease of use, makes 
SolidWorks a powerful design tool. Complex three-dimensional parts with contoured 
surfaces and detailed features can be modeled quickly and easily with Solid-Works. 
Then, many parts can be assembled in a virtual environment to create a computer model 
of the finished product. In addition, traditional engineering drawings can be easily 
extracted from the solids models of both the parts and the final assembly. This approach 
opens the door to innovative design concepts, speeds product development, and 
minimizes design errors. The result is the ability to bring high-quality products to market 
very quickly. 
 
CONSTRAINT-BASED SOLIDS MODELING 
The constraint-based solids modeling used in SolidWorks makes the modeling process 
intuitive. The 3-D modeling begins with the creation of a 2-D sketch of the profile for the 
cross section of the part. The sketch of the cross section begins much like the freehand 
sketch of the face of an object. The initial sketch need not be particularly accurate; it 
needs only to reflect the basic geometry of the part’s cross-sectional shape. Details of the 
cross section are added later. The next step is to constrain the two-dimensional sketch by 
adding enough dimensions and parameters to completely define the shape and size of the 
two-dimensional profile. The name constraint-based modeling arises because the shape 
of the initial two-dimensional sketch is “constrained” by adding dimensions to the sketch. 
Finally, a three-dimensional object is created by revolving or extruding the two-
dimensional sketched profile. Figure 1 shows the result of revolving a simple L-shaped 
cross section by 270o about an axis and extruding the same L-shaped cross section along 
an axis.  

Axis 

Figure 1 Revolved and extruded solid models of an L-shaped cross-section. 
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In either case, these solid bodies form the basic geometric solid shapes of the part. Other 
features can be added subsequently to modify the basic solid shape. Once the solids 
model is generated using SolidWorks, all of the surfaces have been automatically 
defined, so it is possible to shade it in order to create a photorealistic appearance. It is 
also easy to generate two-dimensional orthographic views of the object. Solid modeling 
is like the sculpting of a virtual solid volume of material. Because the volume of the 
object is properly represented in a solids model, it is possible to slice through the object 
and show a view of the object that displays the interior detail (sectional views). Once 
several solid objects have been created, they can be assembled in a virtual environment to 
confirm their fit and to visualize the assembled product. Solids models are useful for 
purposes other than visualization. The solids model contains a complete mathematical 
representation of the object, inside and out. This mathematical representation is easily 
converted into specialized computer code that can be used for stress analysis, heat-
transfer analysis, fluid-flow analysis, and computer-aided manufacturing. 

Getting Started in SolidWorks 
Introduction and Reference 
 
SolidWorks Corporation developed SolidWorks® as a three-dimensional, feature-based, 
solids-modeling system for personal computers. Solid modeling represents objects in a 
computer as volumes, rather than just as collections of edges and surfaces. Features are 
three-dimensional geometries with direct analogies to shapes that can be machined or 
manufactured, such as holes or rounds. Feature-based solid modeling creates and 
modifies the geometric shapes of an object in a way that represents common manufactur-
ing processes. This makes SolidWorks a very powerful and effective tool for engineering 
design. 

As with other computer programs SolidWorks organizes and stores data in files. Each file 
has a name followed by a period (dot) and an extension. There are several file types used 
in SolidWorks, but the most common file types and their extensions are 

 Part files .prt or .sldprt 
 Assembly files .asm or .sldasm 
 Drawing files .drw or .slddrw 

Part files are the files of the individual parts that are modeled. Part files contain all of the 
pertinent information about the part. Because SolidWorks is a solids-modeling program, 
the virtual part on the screen will look very similar to the actual manufacture part. 

Assembly files are created from several individual part files that are virtually assembled 
(in the computer) to create the finished product.  

Drawing files are the two dimensional engineering drawing representations of both the 
part and assembly file. The drawings should contain all of the necessary information for 
the manufacture of the part, including dimensions, part tolerances, and so on. 

The part file is the driving file for all other file types. The modeling procedure begins 
with part files. Subsequent assemblies and drawings are based on the original part files. 
One advantage of SolidWorks files is the feature of dynamic links. Any change to a part 
file will automatically be updated in any corresponding assembly or drawing file. 
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Therefore, both drawing and assembly files must be able to find and access their 
corresponding part files in order to be opened. SolidWorks uses information embedded 
within the file and the filename to maintain these links automatically. 

Starting SolidWorks 
SolidWorks runs on computers running the Microsoft Windows® operating system. You 
open SolidWorks in the same way that you would start any other program. 

Checking the Options Settings 
The SolidWorks window that appears on the computer screen looks similar to the 
standard Microsoft Windows interface, as shown in Figure 2. The top line of the window 
is the Menu bar from which menus for various operations can be opened. Below the 
Menu bar are the toolbars which provide access to a variety of commonly used 
operations, or tools, with a single click of the mouse button. Toolbars can also extend 
down the right and left sides of the window. They may or may not be shown on your 
screen. At this point, most items within the toolbars are grayed out. This indicates that 
they are not presently available for use. 

 
Figure 2 SolidWorks window. 
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Tool bars  
To specify which toolbars are displayed on the screen, select View Tool-bars (i.e., select 
Toolbars from the View menu). Be sure that the Features, Sketch, Standard, Standard 
Views and View toolbars are checked, as shown in Figure 3. If they are not, click on each 
of these items until all are checked. If other toolbars are checked, click on them to 
uncheck them. It may be necessary to select View, then Toolbars again to display the 
menu after checking (or un-checking) an item to confirm that the desired change was 
made. The Standard Views toolbar may appear as a dialog box in the Graphics Window 
instead of as a toolbar. If so, click the blue bar at the top of the dialog box with the left 
mouse button and drag it to the toolbar at the upper right of the Graphics Window. 
Release the mouse button. The dialog box should change to a toolbar. 

 
Figure 3Toolbars menu. 

• The Sketch  toolbar contains tools to draw lines, circles, rectangles, arcs, and so 
on. 

• The Features toolbar contains tools that modify sketches and existing features 
of a part. 

• The Standard toolbar contains the usual commands available for manipulating 
files (Open, Save, Print, and so on), editing documents (Cut, Copy, and Paste), 
and accessing Help. 
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• The Standard Views toolbar contains common orientations for a model. 

• The View toolbar contains tools to orient and rescale the view of a part. 

You can find these toolbars around the Graphics Window by checking and un-checking 
them in the View⇒Toolbars menu. The toolbars will appear as you check them and 
disappear as you uncheck them. Currently, most of the items in the tool-bars are grayed 
out, since they are unusable. They will become active when they are available for use. Be 
sure that the Toolbars menu looks like the one in Figure 3 before continuing. Click any 
open spot in the Graphics Window to close all menus. 

Getting Help 
If you have questions while you are using SolidWorks, you can find answers in several 
ways: 

• Click SolidWorks Help Topics in the Help Menu bar. 

• Move the cursor over a toolbar button to see the ToolTip, which indicates the 
name of the tool. 

• Move the cursor over buttons or click menu items. The Status bar at the bottom 
of the SolidWorks window will provide a brief description of the function. 

• Click the Help button in a dialog box. 

• Refer to the Solid Works User’s Guide, by SolidWorks Corporation, for detailed 
information. 

Creating a New Part 

With the SolidWorks window open, select File⇒New in the Menu bar, or click the New 
button (a blank-sheet icon) in the Standard toolbar. 

The New Solid Works Document dialog box appears as shown in Figure 4. You will be 
modeling a new part. If Part is already highlighted, click OK. If it is not highlighted, 
click Part, then OK.  
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                          Figure 4 New document window.    

A new window appears with the name Partl, as shown in Figure 5. On the left side of the 
window is the Feature Manager Design tree.  

 

Sketch toolbar 

Figure 6 New part window. 
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It contains a list of the features that have been created so far. Every new part starts with 
six features: annotations, lighting, three datum planes, and an origin. The datum planes 
are three mutually perpendicular planes that are created in space as references for 
constructing features of the part that you are modeling. The three planes intersect at the 
origin, which is in the center of the Graphics Window. The arrows in the lower left corner 
of the Graphics Window show the coordinate directions. As the part is modeled, the 
features that are created will appear in the Feature Manager Design tree. These features 
can be highlighted or modified by clicking on them in the Feature Manager Design tree. 
For example, click on a plane or the origin in the Feature Manage Design tree to highlight 
these items. Front is the plane of the screen, Top is the horizontal plane perpendicular to 
the screen, and Right is the vertical plane perpendicular to the screen. Finish by clicking 
on Part1 in the Feature Manager Design tree, so that no plane is highlighted. 

Sketching 
Every part begins as a cross section sketched on a two-dimensional plane. Once a sketch 
is made, it is extruded or revolved into the third dimension to create a three-dimensional 
object. This is the base feature of the part.  

The Sketch toolbar, shown in Figure 6, has tools to set up and manipulate a sketch of a 
cross section. Find the Sketch toolbar. Move the cursor over each of the tools, but do not 
click on any of the tools. The Tool Tips should appear, displaying the name of each tool. 

• Select highlights sketch entities; drags sketch entities and endpoints and 
modifies dimension values. 

• Grid activates the Grid/Snap field of the Document Properties dialogue box to 
change the sketching environment. 

• Dimension adds dimensions to sketch entities. 

• Sketch opens and closes sketches as a part is created. 
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                 Figure 6 Document properties dialog box: Units  

 

To set the units and grid size to be used, click the Grid toolbar button with the left mouse 
button. Document properties dialog box shown in Figure 6 will appear. Click Units on 
the left side of the dialog box to set the units. Setup appropriate units (inches or mm) with 
the desired number of decimal places or fraction denominator.  

Click Grid/Snap on the left side of the dialogue box to control the grid that will appear 
on the screen when a cross-section is sketched. Be sure that all three of the boxes under 
Grid are checked, as shown in Figure 7. Adjust the grid spacing to desired values. 
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         Figure 7 Document properties dialog box: Grid/Snap 

 

Snap controls the way in which sketched lines are related to the grid. The points that are 
sketched should “snap” to the nearest intersection of grid lines when they are close. Click 
Go To System Snaps. If not, click the box Grid to check it as shown in Figure 8. 
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Figure 8 Document properties dialog box: System Snap  

Click Detailing on the left side of tile dialogue box. If necessary, change Dimensioning 
standard to ANSI for inch units and ISO in case of mm units. Then, click OK at the 
bottom of the dialogue box to accept the values. 

Open a new sketch by selecting Insert Sketch, or by clicking the Sketch button (a 
pencil drawing a line) in the Sketch toolbar. (Note that, for most commands in 
SolidWorks, it is possible to initiate the command from either the Menu bar or the 
toolbars.) A grid should appear on the screen, as shown in Figure 9, indicating that the 
sketch mode is active. The window’s name changes to Sketch of Part1. In the bottom 
right corner of the screen, the Status bar reads Editing Sketch. You are now ready to 
sketch in the Front plane. 

The Sketch toolbar, shown in Figure 9, contains tools to create and modify two-
dimensional features, called Sketch Entities. Sketch Entities are items that can be drawn 
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on the sketch. The following Sketch Entities and Sketch Tools are available: 

 
Figure 9 New sketch window. 

 

• Line  creates a straight line. 

• Centerpoint Arc  creates a circular arc from a center point, a start point, 
and an end point. 

• Tangent Arc  creates a circular arc tangent to an existing sketch entity. 

• 3 Pt Arc  creates a circular arc through three points. 

• Circle  creates a circle. 

• Spline creates a curved line that is not a circular arc. 

• Polygon creates a regular polygon. 

• Rectangle  creates a rectangle. 

• Point  creates a reference point that is used for constructing other sketch 
entities. 
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• Centerline  creates a reference line that is used for constructing other sketch 
entities. 

• Convert Entities  creates a sketch entity by projecting an edge, curve, or 
contour onto the sketch plane. 

• Mirror  reflects entities about a centerline. 

• Fillet  creates a tangent arc between two sketch entities by rounding an 
inside or an outside corner. 

• Offset Entities  creates a sketch curve that is offset from a selected sketch 
entity by a specified distance. 

• Trim  removes a portion of a line or curve. 

• Construction Geometry creates entities that aid in sketching. 

• Linear Sketch Step and Repeat creates a linear pattern of sketch entities. 

• Circular Sketch Step and Repeat creates a circular pattern of sketch entities. 

Move and hold the cursor over each of the tools to display its function but do not click on 
the tool. Note the description of each tool in the Status bar at the bottom of the 
SolidWorks window. Some of these tools may not he included in the toolbar or other 
tools may be available, depending on the way in which it was previously set up. All tools 
are available in the Tools Menu. 
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