
Week and Session Hours Chapter The Main Topic Sub-Topic Description

Need of Computers
- What is a Computer?

- Benefits of a Computer.

- Super Computers.

- Mainframe Computers.

- Microcomputers.

    - Personal Computers.

    - Laptop- Computers.

    - Personal Digital Assistant (PDA and Smart Phones) .

- Use of computers in education.

- Use of computers in government services.

- Use of computers in aviation services and air navigation.

- Use of computers in banking services.

- Use of computers in medical services.

- Use of computers in e-commerce.

Number System - Decimal Number System, Binary Number System, Octal Number System,Hexadecimal Number System.

The definition of hardware - Whats is Hardware?

Input Device
- What is Input? What are Input devices? Examples of Input devices: Keyboard, Mouse, Joystick, Scanner, Audio-Input Devices: Microphone, 

……..
Output Device - What are Output devices? Examples of Output devices: Monitor, Printer, Audio-Output Devices , …….

- What is a Processor/ Microprocessor?

     -Control Unit (CU ) & Arithmetic-Logic Unit (ALU).

- Random Access Memory (RAM ) 

- Read Only Memory (ROM).

- Comparison between RAM and ROM.

- Whats are Storage Devices?

-Types of Storage Devices (Hard Disk Drive, floppy Disk, CD-ROM, CD-R, CD- RW, DVD, Zip Disks, Backup Tapes).

- What is bit, Byte, K.Byte, M.Byte, G.byte, T.Byte ?

- Comparison between The Units of measurement.

Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description

The definition of Software - What is Software?

- What is Operating System?

- Operating system functions.

- Interfaces Of Operating Systems. (Command Line  and GUI  )

- Examples of Operating Systems.

Application Software - Types of Application Softwares. (General Use and Specific Use ).

- What is a Programming Language?

- Examples of Programming Languages.

- The Life Cycle of creating a program.(Analyzing, Designing, Coding and Testing).

- What is a Network?

- What are the benefits of Networks?

- Types of Networks According to Network's Transport Media. (Wireless and Wired Networks ).

-Types of Networks According to the geographical area (LAN, MAN and WAN ).

- Types of Networks Accoding to the network management system. (Peer To Peer, Client-Server ).

Types of Servers - The Mail Server, The Application Server, The Printer Server, ……

Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description

- What are the Benefits of the Password?

- Tips for creating passwords.

- Tips for the use of passwords.

- The Viruses.

- The Worms.

- The Spyware.

- The Hoax.

- The Phishing Scam.

- The Trojan Horses.

- Ways Incidence of Malicious programs.

- How to Protect Your Computer from Malicious Programs.

- What is Backing up?

- Where can I Backup my Files?

The Copy Right - What are Copy Rights?
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HOUR 1  All About Computers Introduction to Information security The Password

HOUR 2 

           Central Processing Unit         (CPU)

Main Memory

Storage Devices

Units of measurement used in the 

Computer
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HOUR 1  All About Computers
Computer Components

(The Software)

Operating System (System Software)

Programming Languages

All About Computers
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HOUR 1 All About Computers
Introduction and General Concepts about 

Computers

Types of Computer Systems

Ffields of Computer uses

HOUR 2  All About Computers
Computer Components

(The Hardware)

All About Computers

Introduction to Information security The Malicious Software

The Backup and the Copy Rights
The Backup

HOUR 2 All About Computers Introduction to Networks

Introduction to Networks

Classifications of Networks



Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description

Introduction to Windows7
- Features of Windows7.

- Logging On to Windows7.

Exploring the Desktop - Windows Desktop, Icon, Tool Tip, Icons Provided By Windows, Taskbar,  Start button, Recycle Bin.

- Opening Desktop Background window (Personalization Window).

- Applying Desktop background.

-  Picture Position and Color Selection.

- Desktop Slideshow.

- Setting Picture as Background.

- Screen Saver.

-  Applying a Screen saver.

-  Previewing Screen Saver.

- Screen Resolution.

-  Changing Display Settings.

- Themes.

- Different Types of Themes.

- Applying Themes.

- Self Learning on the previous Topics.

- Practicing on the previous Topics.

- Quiz and Take a challenge.

Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description

- Views of the Desktop Icons.

-  Arranging Icons.

- Showing and Hiding the Desktop Icons.

- Creating Shortcuts.

-  Deleting shortcuts.

- Show Desktop.

- Quick Launch Icons.

- Notification Area.

- Jump-Lists.

-  Taskbar Properties.

- Adding Toolbar to Taskbar.

- Customizing Taskbar.

- The Contents of the Start Menu.

- Search Box.

-  Run Command.

- All Programs.

- Shut-Down Button.

- Open the Recycle Bin.

- Sending Files to Recycle Bin.

- Restoring files from Recycle Bin.

- Emptying  the Recycle Bin.

- Self Learning on the previous Topics.

- Practicing on the previous Topics.

- Quiz and Take a challenge.

Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description

-  Parts of Window.

- Active Window.

-  Menu Bar.

-  Title Bar.

- Maximize/Minimize/Close buttons.

- The Restore Button.

-  Scroll Bars.

-  Window Borders.

- Work Space.

- Toolbar.

- Resizing and Moving a Window.

- Maximize a window using snap.

-  Expand a window vertically using snap.

- Arranging windows automatically.

- Cascade Windows.

- Show Windows Stacked.

- Show windows side by side.

- Switching between windows using ALT+TAB.

- Windows Flip 3D.

- Switching between windows using Flip 3-D.

Files, Folders and Libraries

- File

- Folders 

- Libraries

- Explorer Views.

- Navigation Pane.

- Creating Folders and Libraries.

- Selecting Multiple Files.

- Copying File or Folder.

- Moving File or Folder.

- Copy or Move a File or Folder Using Drag and Drop.

- Renaming Files and Folders.

- Hidden files.

-  Read-Only

- Setting a folder to read-only.

- Creating Files using Notepad Application.

- Self Learning on the previous Topics.

- Practicing on the previous Topics.

- Quiz and Take a challenge.

Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description

-  Opening Control Panel.

-  Category View.

- Changing System Date and Time.

- Calendar settings.

- Available Gadgets.

-  Adding Gadgets.

- View or Hide Gadgets.

- Mouse Pointer.

- Changing Mouse Pointer.

- Settings.

- Customization.

- Installing and removing Languages.

- Changing Windows Interface.
System - Specifications of the Computer and the Operating System.

- Self Learning on the previous Topics.

- Practicing on the previous Topics.

- Quiz and Take a challenge.

Changing Mouse Settings

Region and language

HOUR 2 Windows 7 Self Learning and Practicing Using Era System

Working with Files and Folders

HOUR 2 Windows 7 Self Learning and Practicing Using Era System
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HOUR 1 Windows 7

Resizing & Moving Windows

Working with Multiple Windows

Windows Explorer

Explorer Views

Customization

Control Panel

Date & Time Settings

Gadgets
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HOUR 1 Windows 7 Personalizing Windows7

Working on the Desktop

Creating and Deleting Shortcuts

Using the Taskbar

Taskbar Settings

Start Button

The Recycle Bin

HOUR 2 Windows 7 Self Learning and Practicing Using Era System
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HOUR 1 Windows 7

Working With Windows

Parts of a Window

Operating System (Windows 7 )
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HOUR 1 Windows 7

Getting Started

Personalizing Windows7

Changing the Desktop Background

- Desktop Background.

Applying a Screen Saver

Changing the Display Settings

Applying Themes

HOUR 2 Windows 7 Self Learning and Practicing Using Era System



Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description

Overview of Word Processing
- What is Word Processing?

- Starting Word 2010.

- Explanation of User Interface

- Quick access toolbar.

- What is a Ribbon?

- Contextual Tabs.

- Dialog Box Launcher.

- Work Area.

- Insertion point.

- Scroll Bars.

- Status Bar.

- View Buttons.

- Zoom Buttons.

- Adding Commands to Quick access toolbar.

- Removing Commands from Quick access toolbar.

- Minimize Ribbon.

- Using Help and tooltip.

- Using Access keys.

- Creating a New Document.

- Entering Text, Use of Enter & Tab key.

- Selecting Text.

- Using delete & backspace key
- Use of Undo & Redo option.

- Self Learning on the previous Topics.

- Practicing on the previous Topics.

- Quiz and Take a challenge.

Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description

- Navigation in the document using: Mouse, Scroll bars, keyboard shortcuts .

- Using Navigation pane to search specific text to browse the pages in your document.

- Using Go To option.

- Saving a Document.

- Use of Save As option.

- Closing a Document.

- Opening a Document.

- Opening a Recent Document.

- Pinning a Recent Document.

- Printing a document.

- Print Setting.

- Using Quick print tool.

Introduction - The Home Tab.

- Copy.

- Cut.

- Clipboard Task Pane.

- Paste.

- Paste Options.

- Format Painter.

- Using Drag and Drop.

- Self Learning on the previous Topics.

- Practicing on the previous Topics.

- Quiz and Take a challenge.

Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description

- Font.

- Font Size.

- Grow Font and Shrink Font.

- Font Color.

- Bold.

- Italic.

- Underline.

- Change Case.

- Text Highlight Color.
- Text Effects.

- Clear Formatting.

- Strikethrough.

- Subscript and Superscript.

- The Font Dialog Box.

- Alignment.

-  Indentation.

- Using the Ruler for Indentation.

- Line Spacing.

- Bullets.

- Numbering.

- Borders.

- Shading.

- The Paragraph Dialog Box.

- Self Learning on the previous Topics.

- Practicing on the previous Topics.

- Quiz and Take a challenge.

Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description

The Styles Group - Applying Heading styles to text.

- Find.

- Replace.

- Replace All.

- Selecting Text and objects.

Introduction - The Insert Tab.

- Cover Page.

- Blank Page.

- Page Break.

- Inserting a Table.

- Explain contextual tabs Design & Layout.

- Entering Table Data.

- Sizing and Moving a Table.

- Use contextual Layout tab to insert additional rows or columns.

- Merging Cells.

- Splitting Cells.
- Use contextual Design tab to apply table styles from the gallery.

- Shading and Borders

- Converting Text to a Table.

- Converting a Table to Text.

- Deleting a Table.

- Self Learning on the previous Topics.

- Practicing on the previous Topics.

- Quiz and Take a challenge.

Word Processing
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HOUR 1 Word Processing

The Home Tab
The Editing Group

The Insert Tab

The Pages Group

The Tables Group

HOUR 2

Self Learning and Practicing

Self Learning and Practicing Using Era System
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HOUR 1 Word Processing

Getting Started

Navigating through a Document

The File Tab

The Home Tab
The Clipboard Group

HOUR 2 Word Processing
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HOUR 1 Word Processing The Home Tab

The Font Group

The Paragraph Group

HOUR 2 Word Processing Self Learning and Practicing Using Era System

Word Processing (Microsoft Word 2010 )
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HOUR 1 Word Processing Getting Started

User Interface

Word Processing Self Learning and Practicing Using Era SystemHOUR 2 

Using Era System

Creating a Simple Document



Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description

- Inserting a Picture.

- The contextual tab Format.

- Applying Artistic Effects.

- Cropping a Picture.

- Text wrapping options.

- Changing Picture position.

- Inserting Clip Art.

- Inserting Shapes.

- Rotating, Re-sizing & adjusting shapes.

- Inserting a Smart Art, Inserting Chart.

- Self Learning on the previous Topics.

- Practicing on the previous Topics.

- Quiz and Take a challenge.

Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description

- Inserting Hyperlink.

- Removing Hyperlink.

- Inserting Bookmark.

- Deleting a Bookmark..

- Adding Header or Footer to a document.

- Close Header & Footer option.

- Inserting page number.

- Self Learning on the previous Topics.

- Practicing on the previous Topics.

- Quiz and Take a challenge.

Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description

- Inserting Text box.

- Using WordArt.

- Applying Drop Cap effect.

- Insert Date & Time and use of update automatically option.

- Inserting Symbols.

Introduction - The Page Layout Tab.

- Margins.

- Orientation.

- Size.

- Columns.

- Line Numbers.

- Hyphenation.

- Adding Watermark.

- Removing Watermark.

- Applying page color.

- Page Borders.

- Self Learning on the previous Topics.

- Practicing on the previous Topics.

- Quiz and Take a challenge.

Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description

Introduction - The References Tab.

- Inserting Table of Contents.

- Update Table of Contents

- Deleting Table of Contents.

- Inserting Footnotes.

- Deleting Footnotes.

Introduction The Review Tab

The Proofing Group Spelling and Grammar check.

- Inserting comments.

- Deleting comments.

- Viewing Next and Previous Comments

- Self Learning on the previous Topics.

- Practicing on the previous Topics.

- Quiz and Take a challenge.

Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description

Introduction The View Tab

- Print Layout.

- Full Screen Reading.

- Web Layout.

- Outline.

- Draft.

- Show/Hide Ruler.

- Gridlines.

Using the PDF Format -  Saving document as pdf.

Creating Template - Saving document as template.

- Self Learning on the previous Topics.

- Practicing on the previous Topics.

- Quiz and Take a challenge.

Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description
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HOUR 1 Word Processing
The View Tab

The Document Views Group

The Show Group

Other Features

HOUR 2 Word Processing Self Learning and Practicing

HOUR 2 Word Processing Self Learning and Practicing Using Era System

Using Era System
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) HOUR 1 All About Computers, Windows7, Microsoft  Word 2010, Examination Practice Session

HOUR 2 All About Computers, Windows7, Microsoft  Word 2010, Examination Practice Session

The Review Tab

The Comments Group

HOUR 2 Word Processing Self Learning and Practicing Using Era System

HOUR 1 Word Processing

The Insert Tab The Text and Symbols Groups

The Page Layout Tab

The Page Setup Group

The Page Background Group

Word Processing
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HOUR 1 Word Processing

The References Tab
Table of Contents Group

The Footnotes Group

Self Learning and Practicing Using Era System
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Self Learning and Practicing Using Era System
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HOUR 1 Word Processing The Insert Tab

The Links Group

The Header & Footer Group

HOUR 2 

Word Processing
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HOUR 1 Word Processing The Insert Tab The Illustrations Group

HOUR 2 



Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description

Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description

Introduction - Starting PowerPoint 2010.

- Using Help.

- What is a Slide Pane?

- Placeholder.

- Slides Tab.

- Outline tab.

- Notes Pane.

- Resizing Panes.

- Use of Status Bar.

- View Buttons.

- Zoom Buttons..

- Creating a New Presentation.

- Using Templates.

- Entering Text.

- Editing Text.

- Resizing & Moving Placeholders.

- Selecting Slides - Use of Ctrl & Shift key.

- Moving Slides using drag & drop feature.

- Using Slides Tab - Right click option to Insert a new slide.

- Duplicate a slide.

- Delete a slide.

- Introduction

- Saving a Presentation.

- Difference between Save & Save As option.

- Open a Presentation.

- Close a Presentation.

- Open a Recent Presentation.

- Print a presentation.

- Specifying Print Settings.

- Self Learning on the previous Topics.

- Practicing on the previous Topics.

- Quiz and Take a challenge.

Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description

Introduction - The Home tab.

- Cut.

- Copy.

- Paste.

- Paste Options.

- Format Painter.

- Insert New Slide.

- Change Slide Layout.

- Reset Slide.

- Change Font.

- Font Size.

- Use of Increase Font Size and Decrease Font Size options.

- Change Font Color.

- Apply Bold, Italic, Underline, Shadow, Strikethrough effects to selected text.

-  Modify Character Spacing.

- Change font Case.

- Using Clear All Formatting option.

- The Font Dialog Box.

- Applying Bullets to list.

- Using Picture Bullets.

- Using Numbered list.

- Indentation.

- Line Spacing.

- Align Text Left, Center, Right, Justify; Align Text Top, Middle, Bottom.

- Split text into two or more columns.

- Change Text Direction.

- Inserting Shapes.

- Adjusting shape Size.

- Using Quick Styles tool.

- Use of options like Arrange, Shape Fill, Shape Outline, Shape Effects

- Using Find & Replace.

- Selecting multiple object.

- Using selection pane.

- Self Learning on the previous Topics.

- Practicing on the previous Topics.

- Quiz and Take a challenge.

Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description

Introduction - The Insert Tab.

- Inserting a Table.

- Entering Table Data.

- Sizing and Moving a Table.

- Merging Cells.

- Applying Table Styles.

- Inserting Pictures.

- Resizing & Moving pictures using mouse.

-  Applying Picture Styles, Picture Border & Picture Effects..

- Inserting Clip Art.

- Use of Screenshot & Screen Clipping options.

- Inserting Smart Art.

-  Adding shape.

- Changing color.

- Styles & Resizing smart art.

- Using Text Pane to edit text of Smart Art.

- Inserting Chart.

- Applying Chart Styles & Show data labels.

- Inserting Hyperlink within the presentation.

- Using action button.

- Self Learning on the previous Topics.

- Practicing on the previous Topics.

- Quiz and Take a challenge.

Self Learning and Practicing Using Era System

HOUR 2 Presentation Graphics Self Learning and Practicing Using Era System

W
ee

k-
7

 S
es

si
o

n
 (

2
0

) 
 

HOUR 1 

Presentation Graphics

The Home tab

The Clipboard Group

The Slides Group

The Font Group

The Paragraph Group

The Drawing Group

The Editing Group
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HOUR 1 Presentation Graphics The Insert Tab

The Tables Group

The Images Group

The Illustrations Group

The Links Group

HOUR 2 Presentation Graphics
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HOUR 1&2  

Examination 1

All About Computers , Windows7 , Microsoft  Word 2010

Presentation Graphics (Microsoft PowerPoint 2010 )
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HOUR 1 Presentation Graphics Getting Started

The User Interface

Creating a Simple Presentation

Working With a Presentation

The File Tab

HOUR 2 Presentation Graphics Self Learning and Practicing Using Era System



Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description

- Inserting Text box.

- Applying Shape styles to text box.

-  Inserting Footer.

- Inserting WordArt.

- Inserting Date & Time into footer.

- Adding Slide number to footer.

- Inserting Symbols..

- Inserting a Video.

- Trimming a Video.

- Inserting Audio.

Introduction - The Design Tab.

- Use of Page Setup options.

- Changing Slide orientation.

- Using Themes Gallery.

- Use of Background Styles option.

- Inserting picture as slide background.

- Self Learning on the previous Topics.

- Practicing on the previous Topics.

- Quiz and Take a challenge.

Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description

Introduction - The Transitions Tab.

- Use of Preview button.

- Applying Slide Transition effects.

- Use of Sound, Duration & Apply to All options.

- Advance slide: Using On mouse click option & time setting.

Introduction - The Animations Tab.

- Use of Preview button for Animations.

- Applying Animation effects to an object.

- Applying more than one animation effect.

- Using Animation pane.

- Self Learning on the previous Topics.

- Practicing on the previous Topics.

- Quiz and Take a challenge.

Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description

Introduction - The Slide Show Tab.

- From Beginning.

- From Current Slide.

- Navigation during slide show using the right-click option for moving to Next, Previous, Last Viewed slide.

- Hiding a slide.

- Use of Spell check feature.

- Exploring Presentation Views like Normal, Slide Sorter. Notes Page and Reading View.

- What is Slide Master.

- Changing the Slide Master.

- Save presentation in .ppsx format.

- Self Learning on the previous Topics.

- Practicing on the previous Topics.

- Quiz and Take a challenge.

Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description

- Overview of Spreadsheet.

- Features of Electronic Spreadsheets.

- Features of Excel 2010.

- Starting Excel 2010.

- User Interface of Excel 2010.

- Quick Access Toolbar.

- Ribbon.

- Contextual Tabs.

- Dialog Box Launcher.

- Worksheet, Active Cell.

- Formula Bar.

- Name Box.

- Sheet Tabs.

- Scroll Bars.

- Status Bar.

- View Buttons.

- Zoom Buttons.

- Resizing the Formula Bar and Name Box.

- Help.

- Galleries and Live Previewing.

- Creating a Workbook.

- Using Templates.

- Downloading Templates.

- Moving Between Cells.

- Entering Data.

- Adjusting Column Width.

- Self Learning on the previous Topics.

- Practicing on the previous Topics.

- Quiz and Take a challenge.

HOUR 2 Presentation Graphics Self Learning and Practicing Using Era System

Spreadsheet (Microsoft Excel 2010 )

W
ee

k-
9

  S
es

si
o

n
 (

2
5

)

HOUR 1 Spreadsheet Getting Started

Introduction

The User Interface

Creating a New Workbook

HOUR 2 Spreadsheet Self Learning and Practicing Using Era System

Presentation Graphics Self Learning and Practicing Using Era System
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HOUR 1 Presentation Graphics

The Slide Show Tab
Slide Show Tab Commands

Other Features Spellings, Views and Masters
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HOUR 1 Presentation Graphics

The Insert Tab

The Text and Symbols Group

The Media Group

The Design Tab
Design Tab Commands

HOUR 2 Presentation Graphics Self Learning and Practicing Using Era System
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HOUR 1 Presentation Graphics

The Transitions Tab

Transitions Tab Commands

The Animations Tab
Animations Tab Commands

HOUR 2 



Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description

- Navigating a Worksheet.

- keyboard shortcuts.

- Selecting multiple cells.

- Using the Name Box.

- Editing Data.

- Editing through Formula Bar.

- Undoing and Redoing Editing Changes.

- Inserting Worksheet.

- Deleting Worksheet.

- Renaming Worksheet.

- Moving and Copying Worksheet.

- Moving/Copying Worksheet to another Workbook.

- Changing Tab Color.

- Other Sheet Options.

- Save As.

- Create A New Folder.

- Closing a Workbook.

- Opening a Workbook.

- Open a Recently Used Workbook.

- Printing a workbook.

- Self Learning on the previous Topics.

- Practicing on the previous Topics.

- Quiz and Take a challenge.

Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description

Introduction - The Home Tab.

- Copy.

- Cut.

- Paste.

- Format Painter.

- Font.

- Font Size.

- Increase Font Size.

- Decrease Font Size.

- Font Color.

- Bold.

- Italic.

- Underline.

- Borders.

- Fill Color.

- The Format Cells Dialog Box.

- Align Text Left.

- Center, Align Text Right.

- Top Align.

- Middle Align.

- Bottom Align.

- Orientation.

- Increase Indent, Decrease Indent.

- Wrap Text.

- Merge &  Center.

- Self Learning on the previous Topics.

- Practicing on the previous Topics.

- Quiz and Take a challenge.

Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description

- Insert.

- Inserting Multiple Rows and Columns.

- Delete Multiple Rows and Columns.

- Inserting Cells, Shifting Cells.

- Format.

- Sum.

- Using Auto Fill.

- Auto Fill Facts.

- Other Auto Fill Uses.

- Formulas.

- Using Formulas.

- Specifying Decimal Places.

- Increase Decimal, Decrease Decimal.

- Show Formulas.

- Excel Error Messages.

- Auto Calculate.

- Self Learning on the previous Topics.

- Practicing on the previous Topics.

- Quiz and Take a challenge.

Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description

- Types of References.

- Absolute References.

- Copying Formula.

- Referencing Multiple Sheets.

- Using Multiple Sheet References.

- The Sum Function.

- The Average Function.

- The Count Function.

- The CountA Function.

- The MAX Function.

- The MIN Function.

- The IF Function.

- The DATE Function.

- Changing Date Format.

- The LOWER Function.

- The UPPER Function.

- The PROPER Function.

- The LEN function.

- Nested IF.

- The SUMIF function.

- The COUNTIF function.

- Self Learning on the previous Topics.

- Practicing on the previous Topics.

- Quiz and Take a challenge.

Self Learning and Practicing Using Era System

Self Learning and Practicing Using Era System

W
ee

k-
1

0
   

Se
ss

io
n

 (
2

9
)

HOUR 1 Spreadsheet The Home Tab

Absolute and Multiple Sheet References

Using Functions

HOUR 2 Spreadsheet

Self Learning and Practicing Using Era System

W
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HOUR 1 Spreadsheet The Home Tab

The Cells Group

Using Formulas

HOUR 2 Spreadsheet

W
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HOUR 1 Spreadsheet Getting Started

Navigating and Editing a Worksheet

Working With Worksheets

The File Tab

HOUR 2 Spreadsheet Self Learning and Practicing Using Era System
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HOUR 1 Spreadsheet The Home Tab

The Clipboard Group

The Font Group

The Alignment Group

HOUR 2 Spreadsheet



Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description

- Conditional Formatting.

- Applying Conditional Formatting.

- Format as Table.

- Sorting Table Data.

- Cell Styles.

- Sort.

- Filter.

- Filtering Data.

- Find And Select.

- Finding and Replacing.

- The Number Group.

- Self Learning on the previous Topics.

- Practicing on the previous Topics.

- Quiz and Take a challenge.

Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description

Introduction - The Insert Tab.

- Inserting Picture.

- Enhancing Pictures.

- What is a Chart?

- Parts of a Chart.

- Inserting a Chart.

- Moving a Chart.

- Chart Styles.

- Chart Title.

- Labeling Axes.

- Data Labels.

- Coloring Chart Background.

- Changing Chart Data.

- Changing Chart Type.

- Printing a Chart.

- Self Learning on the previous Topics.

- Practicing on the previous Topics.

- Quiz and Take a challenge.

Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description

- Text Box.

- Headers and Footers.

- Themes.

- Page Orientation.

- Background.

- Print Area.

- Print Titles.

- Sheet Options.

- What-If Analysis.

- What is Goal Seek?

- Self Learning on the previous Topics.

- Practicing on the previous Topics.

- Quiz and Take a challenge.

Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description

- Spelling.

- Using Spellcheck.

- Split.

- Vertical Split.

- Quick Splits.

- Freeze Panes.

- Freezing Columns.

- Freezing Rows.

- Using Passwords.

- Creating a Password.

- Removing a Password.

- Self Learning on the previous Topics.

- Practicing on the previous Topics.

- Quiz and Take a challenge.

Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description

- History of Communication.

- Communication Development.

- The Communication Revolution 

- Advantages.

-  History of Internet.

- Modern Internet.

- Applications of Internet.

- Internet as a medium for information.

- Shopping.

- Entertainment 

- Education.

- E-Mail.

- Internet Telephone.

- Advantages and Disadvantages of e-Commerce.

- Tips for online shopping.

- Web Based Applications.

- Internet Security Suites.

- Web Browser.

- URL.

- Self Learning on the previous Topics.

- Practicing on the previous Topics.

- Quiz and Take a challenge.

HOUR 2 Internet Self Learning and Practicing Using Era System
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HOUR 1 Internet Getting Started

Overview of Internet

What is Internet

Uses of Internet

e-Commerce

Web Utilities

Browsers
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HOUR 1 Spreadsheet

The Insert Tab The Text Group

Other Excel Tabs

The Page Layout Tab

The Data Tab

 The Internet

HOUR 2 Spreadsheet Self Learning and Practicing Using Era System
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HOUR 1 Spreadsheet

Other Excel Tabs The Review and View Tabs

Self Learning and Practicing Using Era System

HOUR 2 Spreadsheet Self Learning and Practicing Using Era System

Additional Excel Features Security

Self Learning and Practicing Using Era System
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HOUR 1 Spreadsheet The Insert Tab

The Illustrations Group

The Charts Group

HOUR 2 Spreadsheet

W
ee

k-
1

0
  S

es
si

o
n

 (
3

0
)

HOUR 1 Spreadsheet The Home Tab

The Styles Group

The Editing and Number Groups

HOUR 2 Spreadsheet



Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description

- Address Bar.

- Buttons on the address bar.

- Toolbar.

- Home Page.

- Tabbed Browsing.

- Tabbed Browsing options.

- AutoComplete.

- Scrolling and Selecting links.

- Using frames.

- Displaying Web Pages in Other Languages.

- Notification Bar.

- One Box.

- Pinned Sites.

- Compatibility View.

- In Private Browsing.

- Download Manager.

- Favorites List.

- Adding items to the Favorites list.

- Organizing.

- Creating a Folder.

- Favorites list and Favorites Center.

- Organizing your Favorites.

- Using the History list.

- Deleting item from Favorites.

- Self Learning on the previous Topics.

- Practicing on the previous Topics.

- Quiz and Take a challenge.

Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description

- Printing and saving web pages.

- Previewing a web page.

- Saving an entire web page.

- Saving an image from a page.

- Saving a page without displaying it.

- Search services.

- Category of Search services.

- Crawler or spider.

- Search approaches.

- Using the Search Box.

- Finding search services.

- Change Search Defaults.

- Metasearch Engines.

- Specialized Search Engines.

- Content Evaluation.

- Searching by Topic.

- Searching by Keyword.

- I am Feeling Lucky.

- Advanced Search.

- Preferences.

- Language Tools.

- Self Learning on the previous Topics.

- Practicing on the previous Topics.

- Quiz and Take a challenge.

Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description

- Electronic communication.

- E-mail.

- E-mail address.

- E-mail Concept.

- Types of e-mail services.

- Registration.

- Creating an e-mail account.

- Common features.

- Login Page.

- Basic elements.

- Addresses.

- Subject and Attachments.

- Signature line.

- Spam.

- Spam Blockers.

- CAN-SPAM Act.

- Self Learning on the previous Topics.

- Practicing on the previous Topics.

- Quiz and Take a challenge.

Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description

Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description
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HOUR 1  self revision of All About Computers , Windows7 , Microsoft  Word 2010 , Examination Practice Session

HOUR 2   self revision of All About Computers , Windows7 , Microsoft  Word 2010 , Examination Practice Session
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HOUR 1 Internet

Navigating the Web Printing and Saving Web Pages

Finding Information on the Web

Using Search Services

Google
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HOUR 1 Internet Communication Using E-Mail Using Web E-Mail Services

HOUR 2 Internet Self Learning and Practicing Using Era System
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8
) HOUR 1 Microsoft PowerPoint 2010 , Microsoft Excel 2010, The Internet ,  Examination Practice Session

HOUR 2 Microsoft PowerPoint 2010 , Microsoft Excel 2010, The Internet ,  Examination Practice Session

HOUR 2 Internet

Navigating the Web Using the Favorites Center

HOUR 2 Internet Self Learning and Practicing Using Era System

Self Learning and Practicing Using Era System

W
ee

k-
1

2
   

Se
ss

io
n

 (
3

5
)

HOUR 1 Internet

Getting Started

Internet Explorer (IE10 )

Features of Internet Explorer (IE10 )



Week and Day 

Number
Hours and Sessions Chapter The Main Topic Sub-Topic Description
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HOUR 1&2  

Examination 2

                                      All About Computers , Windows7 , Microsoft  Word 2010, Microsoft PowerPoint 2010 , Microsoft Excel 2010 , The Internet









Overview of Internet

What is Internet

Uses of Internet

e-Commerce

Web Utilities

Browsers

Internet Explorer (IE 9)

Features of Internet Explorer (IE 9)

Navigating the Web Using the Favorites Center

Navigating the Web Printing and Saving Web Pages

Using Search Services

Google

Communication Using E-Mail Using Web E-Mail Services

Hour 1 Internet Internet Concepts What is a Network?

Network, Computer network, Node and Client, Server, Hub, Distributed Processing, Network Interface Cards (NIC), Network Operating Systems 

(NOS), Types of Networks, Local Area Network or LAN, Lan Nodes, Uses, Metropolitan Area Network (MAN), Wide Area Networks (WANs)

Hour 2 Internet Internet Concepts What is a Network?

Network types, Network Architecture, Configurations, Star Network, Star topology, Bus Network, Ring Network, Hierarchical Network, 

Strategies, Terminal Network, Client/server networks, peer-to-peer network, Organizational Internets, Intranets, Extranets, Difference between 

an intranet and extranet, Firewalls, Proxy server
What is WWW? Internet and Web, Accessing the World Wide Web, Applets, Web Surfing

Information Flow Over the Internet Protocols, Rules, TCP/IP, Routers, Features, Identification, Reformatting

Communication Systems

Communication Systems, Connection devices and Data transmission specifications, Sending and Receiving device, Communication Channels, 

Physical Connections, Telephone line, Coaxial cable, Fiber-optic cable, Wireless Connections, Infrared, Broadcast radio, Microwave, Bluetooth, 

Personal area network (PAN), Satellite, Global Positioning System (GPS)

Day 16 Hour 1 Internet Internet Concepts Communication Systems

Communication channels, Connection devices, Modems, Transfer rate, Types of modems, External and Internal modem, PC Card and Wireless, 

Connection Service, Dial-up service, DSL, ADSL and Cable modems, Cellular services, Costs and speeds, Data Transmission and Bandwidth, Voice 

band and Medium band, Broadband

DAY 16 HOUR 2 & 3 Self Learning

DAY 17 HOUR 1, 2 & 3 Self Learning

DAY 18 HOUR 1, 2 & 3 Self Learning

DAY 19 HOUR 1 Self Learning

Hour 3 Internet Internet Concepts

Self Learning (Elective Topic)

Introduction to Self-Learning & Introduction of SL Topic

SL Activity and Project Development

SL Activity and Project Development

SL Activity and Project Development & Project Submission

Internet

Hour 3 Internet
Finding Information on the Web

Day 15

Internet

Day 13 Hour 3 Internet Getting Started

Day 14

Hour 1 Internet Getting Started

Hour 2


