
 DEM استخلاص شبكة الأودية من ملف
  

و من ) أSRTMمن  DEMرتفاع الرقمي تنزيل ملف نموذج الإراجع درس ( DEMيمكنك الحصول على ملف 
تستطيع كامل للمملكة العربيية السعودية  DEMعلى صفحتي ھناك ملف  GIS DATA صفحة بيانات 
وبعدھا تبدأ الخطوات  Toolboxفي صندوق الأدوات  Clipع الجزء الذي تريده من خلال أداة انزالھا وأقتطا

  :التالية
 
  :(Fill Sinks)معالجة القيم الشاذة في الارتفاع -١
 

، كل خلية لھا قيمة ھي الارتفاع عن سطح البحر والخلية ذات  Rasterملف الارتفاع يكون في صورة شبكة خلايا
الارتفاع الأعلى تصب في الخلية ذات الارتفاع الأقل في سلسلة متتابعة وتتواصل ھذه السلسة المتتابعة من ارتفاع 

ا التتابع مثل أن قابلت خلية ذات ارتفاع أكبر كتل مثلاً أو أكبر إلى أصغر إلى أصغر وھكذا، فإذا ما حدث شذوذ في ھذ
انخفاض كبير كحفرة فھذا بالنسبة للبرنامج معناه نھاية الوادي ويبدأ بعدھا في احتساب وادي جديد، وما ھو في 

ذ أو ھذه الحقيقة إلا نفس الوادي ولكن اعترضه حفرة أو تل لذا من البداية يجب أن نقوم بإزالة ھذا الارتفاع الشا
والشكل التالي يوضح لنا   Fill Sinksالحفرة وذلك بإعطائھما متوسط قيم الخلايا المجاورة من خلال العملية المسماه

 .ھذا الأمر
 

 
 SRTM ) ملف الارتفاع الرقمى٥شكل رقم (

 
 
 

تم تفعيله   Spatial Analysisونتأكد من أن  Extensionونختار منھا  Toolsأولا نذھب إلى القائمة  Fill Sinksلعمل
 ثم نختار  Hydrologyومنھا نختار  Spatial Analysisومنه نضغط على  Arc Toolboxلنعمل عليه وبعد ذلك نضغط على

Fill سوف تظھر الشاشة التالية أمامraster  Input surface نختار الملف الجديد(.IMG)  وأمامOutput surface raster  
ندخل اسم ومسار الملف الناتج كما يمكننا تحديد أقصى حد بالنسبة للارتفاع يمكن التعامل معه ولا يختلف الملف 

 .الناتج من حيث الشكل عن الملف المدخل
 

  :IMG Input Surface rasterنقوم بادخال الملف بامتداد
  :Output surface rasterحدد اسم ومسار الملف الناتج عن العمليةن
 



 
 Fill ): يوضح كيفية عمل٦شكل رقم (

  
  :(Flow Direction)اتجاه الجريان -٢
 

للخلايا على أساس الارتفاع ونلاحظ في ھذه الخطوة أننا نعمل على في ھذه الخطوة نقوم بتحديد اتجاه الجريان 
مستوى الخلية وليس على مستوي الرافد بمعني أن كل خلية تؤدي إلى خلية مجاورة لھا تكون أقل ارتفاعاً منھا 

و  ٢و  ١م وكل لھا قيمة ھي رقم من ثمانية أرقا  Rasterوالملف الناتج عن ھذه العملية يكون في صورة خلايا شبكية
 .وكل رقم له مدلوله عن الاتجاه ١٢و  ٦٤و  ٣٢و  ١٦و  ٤
 

 
 
 

بالنظر إلى الشكل أعلاه نجد أن ملف الارتفاع بناء على قيمة الارتفاع للخلية ومقارنتھا مع قيم ارتفاع الخلايا المجاورة 
 :ودلالة ھذه الارقام كالتالي
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 ): يوضح ملف الإرتفاع و ملف إتجاه الجريان لملف الارتفاع وشكل يوضح مدلول كل رقم٩شكل رقم (

 
 

، ونقوم بتحديد اسم ومسار الملف الناتج  Input Surface rasterنقوم بإدخال الملف الناتج عن العملية السابقة في
  Output Flow direction rasterفي
 
 



 
 ): ملف اتجاه الجريان١٠شكل رقم (

 
 

  Open Attribute Layerونختار FlowDir_Fill يمكننا فتح بيانات الملف من خلال الضغط بزر الفأرة الأيمن على الملف
 :فتظھر الشاشة التالية

 

 
 ): يوضح كل اتجاه وعدد الخلايا التى لھا ھذا الاتجاه١١شكل رقم (

 
 

 ١٢٤٢٤تحتوي على إجمالي عدد الخلايا لكل اتجاه أي أن   Countتحتوي الرقم المعبر عن الاتجاه، و  Valueنلاحظ أن
 خلية لھا اتجاه الشرق في الجريان، ولفھم ھذه المرحلة بصورة أفضل يجب أن نستحضر مفھوم خطوط تقسيم المياه

(Watershed) ق تقسيم مياه بمعني أن الأمطار الساقطة سوف تسقط بين الروافد، حيث أن لكل رافد ووادي مناط
  .على ھذا الوادي

 
  



  :(Flow Accumulation)تحديد مناطق تجمع المياه -٣
 

في ھذه المرحلة سوف نقوم بحساب تجمعات الجريان حيث أن الناتج يكون ملف راستر تحتوي كل خلية على قيمة، 
فاعاً عن ھذه الخلية وتصب فيھا أي تتجمع فيھا المياه الساقطة على ھذه القيمة ھي عدد الخلايا التي تكون أكثر ارت

 .ھذه الخلايا
 

ھذا إذا لم تكن غيرت اسمه   FlowDir_Fill1والمطلوب في ھذه المرحلة إدخال الملف الناتج عن عملية اتجاه الجريان
 .وبالنظر إلى الشكل التالي سوف ندرك ما يتم في ھذه المرحلة

 

 
 يسار) يوضح ملف اتجاه الجريان ١٢شكل رقم (

 Flow Accumulation يمين) ملف مناطق تجمع المياه ١٣شكل رقم (
 
 

  In flow direction rasterنقوم بإدخال ملف اتجاه الجريان في
  Output accumulation rasterندخل اسم ومسار الملف الناتج عن العملية في

 

 
 ) يوضح الحاصل فى عملية تحديد أماكن تجمع المياه١٤شكل رقم (

 
 

نجد في الشكل أعلاه أن كل خلية لھا قيمة تمثل عدد الخلايا التي تصب فيھا وھذا بالتحديد ما يتم تحديده في 



حوض الوادي بطبيعة الحال والمجري باللون الأزرق، الملف الناتج عن العملية، فالخلايا التي قيمتھا صفر ليست ضمن 
ونلاحظ أننا لم نصل بعد لتحديد الوادي ولكن تم وضعه في الشكل لتوضيح الفكرة، وأيضا تم تلوين الخلايا التي ھي 

 .بناءً على قيمھا ستصبح ضمن حوض الوادي لنفس السبب
 

وھي الأھم والأخطر في كل المراحل لأن الخطوات  ition) (Streem Definالمرحلة التالية ھي تحديد المجاري المائية
 التالية سوف تبني عليھا، وھناك طريقتين في إنجاز ھذه الخطوة الطريقة الأولى بالنقر بزر الفأرة الأيمن على طبقة

FlowAcc_Flow1 واختيارProperties  ومنھا نختارSymbology  ومن ھذه النافذه نختارClassified  رومنھا نختاClassify  
ولكن السؤال المھم ھنا بناء على ماذا سوف نكتب   Break Valueفتظھر شاشة جديدة فيھا سوف بتغيير القيم في

القيم أو ھذه الفئات وما عدد ھذه الفئات، الحقيقة أنه لا يوجد قاعدة لتحديد عدد وقيم ھذه الفئات وإنما الأمر يرجع 
متر فيمكننا  ٥٠٠إلى  ٥٠فمثلاً نفترض أن المنطقة يترواح الارتفاع بھا من إلى خبرة العمل والتجربة ولا شئ أخر، 

سوف   Ok) وبالضغط على٥٠٠ -٣٠٠) و (٣٠٠ -١٥٠) و (١٥٠ - ٨٠) و (٨٠ – ٦٠) و (٦٠- ٢٠تحديد الفئات كالتالي (
ناً تقل الدقة إلى وأحيا ١:٢٥٠٠٠فكلما تظھر الروافد كما ھي في الخرائط   FlowAcc_Flow1تظھر الناتج على الطبقة

 .١:٥٠٠٠مستوي دقة الخرائط 
 

ويمكن تنزيل ھذه الإضافة وشروح لھا من ھذه الرابط   Arc Hydrology Toolالطريقة الثانية ھي الاعتماد على الاضافة
وسوف نختار من ھذه الصفحة  model-data-p://resources.arcgis.com/content/hydrohtt على موقع شركة ايزري

الموجود لدينا نقوم بتحديد الأدوات التي نقوم بتحميلھا بدءاً من   ArcGISوبناء على إصدار  Tools  –Downloadالجزء
 .٩٫٣إلى الإصدار  ٨٫٣الإصدار 

 
لازم لتنزيل البرنامج بصورة   exeحتوي على شرح للأداة وأخر ملفوسوف يقوم بتنزيل ملف مضغوط به ثلاثة ملفات ت

 .ونقوم بتنصيب الملفين  ArcHydro_setupبالإضافة إلى الأداة نفسھا  ApFrameworkصحيحة ويسمي
 

  .View > Toolbars > Arc Hydro Toolأما عن كيفية استخدام الطريقة الثانية فإننا نقوم بإضافة الأداة عن طريق
 
 
ونقوم بإدخال ملف تجمع   Streem Denifinationنختار منھا  Terrain Preprocessingختار من ھذا الشريط المضافون

وسوف يقوم البرنامج بتحديد اسم ومسار افتراضي للمخرج وسوف تظھر شاشة تالية   Flow Accumulationالمياه
يا اللازمة لاحتساب ذلك الانخفاض رافد أو المساحة نقوم فيھا بتحديد بداية احتساب الروافد إما عن طريق عدد الخلا

بالكيلومتر المربع والرقم الذي سوف نكتبه سوف يمثل الحد الأدني لاحتساب أن ذلك رافد بمعني أن أي مساحة أو 
عدد خلايا يقل عن الرقم المكتوب لن يتم إحتسابه رافداً ضمن شبكة الوادي بما يعضد ما ذكرناه آنفا بأھمية ھذه 

 .لمرحلةا
  
 :إعادة تحديد قيم للخلايا التي لھا قيم كاذبة -٤
 

في المرحلة السابقة تم تحديد مناطق تجمع المياه وحتي يظھر البرنامج ھذه المناطق قام بإعطاء ھذه المناطق 
 في حين أنه كان من المفترض العكس أن مناطق تجمع المياه ھي التي ١الرقم صفر وأعطي باقي المناطق القيمة 

 .يكون لھا قيمة وھذه ما سوف يتم عمله في ھذه المرحلة
 

والمدخل في   SetNullومنھا نختار  Conditionalنختار منھا  Spatial Analyst Toolsنختار منھا  Arc Toolboxمن داخل
ست في فل  Stream Definitionلھا أما إذا قمت بعمل  Classifyبعد عمل  Flow Accumulation Gridھذه المرحلة ھو

فسوف نكتب   Expressionحاجة إلى ھذه المرحلة فقم بتجاوزھا وانتقل إلى المرحلة التالية، وبالنسبة إلى خانة
سوف   Input false raster or constant valueمتر وأمام ٧٠وھذه يعني اعتبار أن أدني ارتفاع ھو   Value lt 70التالي

" والبرنامج سوف يحدد اسم ومسار افتراضي للمخرج من  ١وھي "  نكتب القيمة الكاذبة التي سوف يقوم بتغيرھا
 .نحدد مسار الملف الناتج ونكتب اسمه  Output raster، وأمام SetNull_Flow1ھذه العملية

 
Arc Toolbox > Spatial Analyst Tools > Conditional > SetNull 

 



 
 ) كيفية تحديد قيم للخلايا ذات القيم الكاذبه باستخدام البرنامج١٥شكل رقم (

 
 
  :(Stream Link)ربط الروافد -٥
 

وى الخلية أو الرافد ويجب أن تتصل الروافد داخل الوادي الواحد لذا في جميع المراحل السابقة كان العمل على مست
ونقاط التقاء عناصر الشبكة وإعطاء كل   linksبين الروافد  Junctionفي ھذه الرحلة سوف يتم تحديد نقاط الاتصال

الناتج عن وسوف ندخل الملف   Input Stream Rasterنقطة اتصال قيمة متفردة، والمدخلات في ھذه العملية ھي
فإننا سوف نستخدم الناتج من ھذه   Stream Definitionأما إذا كنا قد قمنا بالعملية  SetNull_Flow1العملية السابقة
 .سوف ندخل ملف اتجاه الجريان الذي تم انجازه في الخطوة الرابعة  Input Flow Directionالعملية، وأمام

 
Arc Toolbox > Spatial Analysis Tools > Hydrology > Stream link 

 
 

 
 ) يوضح الروافد ونقاط اتصال أو إلتقاء ھذه الروافد١٦شكل رقم (

 
 

  Input stream rasterنقوم بادخال الملف الناتج عن العملية السابقة في
  Input flow direction rasterندخل ملف اتجاه الجريان في

  Output rasterنحدد اسم ومسار الملف الناتج عن العملية في



 
  :(Stream Order)حساب الرتب النھرية -٦
 

سوف نقوم في ھذه المرحلة بحساب الرتب النھرية ومعرفة عدد الرتب النھرية وعدد الرتب للوادي رقم له مدلول على 
ة الوادي بالنسبة للجيومرفولوجيا وليس بنفس الأھمية بالنسبة للھيدرولوجيا، إذ أن المھم ھو الخصائص قو

المورفومترية المتعلقة بالنمذجة الھيدرولوجية لذلك فإنك لن تجد ھذه الأمر داخل البرامج المتخصصة في النمذجة 
لعدم أھميتھا من الناحية الھيدرولوجية بالاضافة  وذلك  WMSأو  Water Modeling Systemالھيدرولوجية مثل برنامج

لعدم وضوحه والاتفاق على طريقة الترتيب ھل طريقة استيلر أو شريف ويمكن المقارنة بين الطريقتين في الشكل 
 .أدناه جھة اليسار والصورة جھة اليمين توضح طريقة استيلر بصورة أوضح وتعرض كل رتبة بلون مختلف

 

 
 وطريقة شريف ) تصنيف الرتب حسب طريقة استلر١٧شكل رقم (

 

 
 طبيق تصنيف استلر على الوادىت١شكل رقم (

 
 

نضع   Input Flow Direction Rasterوأمام  Stream Linkوالبيانات المدخلة إلى ھذه الخطوة ھي ناتج العملية السابقة
ثم   Shreveأو  Strahlerملف اتجاه الجريان والبرنامج سوف يعين اسم ومسار الناتج وعليك أن تختار أحد الطريقتين

  .Okنضغط
 

 .فيه الروافد كل رافد حسب الرتبة التي ينتمي إليھا بلون مختلفيظھر   Rasterوالناتج يكون ملف شبكي
 

Arc Toolbox > Spatial Analysis Tools > Hydrology > Stream link 
  Input stream rasterندخل الملف الناتج عن العملية السابقة في

  Input flow direction rasterندخل ملف اتجاه الجريان في
  Output rasterسم الملف الناتج عن العملية فينحدد مسار ونكتب ا



  Method of stream orderingفي  STRAHLER/SHREVEنحتار أحد طريقتي التصنيف
 
  :Vectorإلى ملف خطي  Rasterتحويل الشبكة المائية من ملف شبكي -٧
 

  Stream to Featureبإستخدام الأمر  Vectorھذه المرحلة سوف نقوم فيھا بتحويل الملف الشبكي إلى خطي
  Stream Orderوفيھا نضع الملف الناتج عن العملية السابقة  Input Stream Featureوالمدخلات لھذه العملية ھي

 .نقوم بإدخال ملف اتجاه الجريان والبرنامج سيعين اسم ومسار الملف الناتج  Input Flow Directionوأمام
 .وھو يتضمن رتبة الرافد  Grid Codeوالحقل  Lineونوعه خط pefile Shaناتج ھذه العملية ھو ملف خطي في صورة

 
بالتالي يكون لدينا الروافد والشبكة المائية كاملة ولكن يتبقي لنا بعض الوظائف التي يمكن تعلمھا ثم شرح كيفية 

 .استخراج البيانات التي تستخدم في عمل التحليلات الموفومترية
 

Arc Toolbox > Spatial Analysis Tools > Hydrology > Stream to Feature 
 
 

  Input stream rasterندخل الملف الناتج عن العملية السابقة في
  Input flow direction rasterندخل ملف اتجاه الجريان في

  Output Polyline featuresنحدد مسار ونكتب اسم ناتج العملية في
 

 
 ) ناتج العملية طبقة ملف خطى وتحتھا الملف الشبكى١٩شكل رقم (

 
 
  :(Basin)تحيد مساحة الحوض -٨
 

تتم جميع العمليات على الملف الشبكي كاملاً ولكن إذا أردنا إظھار مساحة الحوض لكل وادي منفصلاً كيف يتم ذلك؟ 
حيث يطلب البرنامج   Hydrologyوالموجود أيضاً ضمن  Basinھذا ما سوف نقوم بعمله في ھذه الخطوة من خلال الأمر

 .حوض وادي له لون يميزه عن الوادي عن بقية الأودية بالملفادخال ملف اتجاه الجريان فقط ليخرج لنا ملف به كل 
 

Arc Toolbox > Spatial Analysis Tools > Hydrology > Basin 
  Input flow direction rasterندخل ملف اتجاه الجريان في

  Output rasterنحدد مسار ونكتب اسم الملف الناتج عن العملية في



 
وذلك من خلال الخطوات التالية،   Vectorن فصل كل واد منفرداً وتحويل إلى صورة خطيةومن الجدير بالذكر أنه يمك

ونختار الحقل الذي سوف يتم أخذه من   Basinوالمدخل إلى ھذه العملية ھو الملف الناتج عن عملية تحديد الأحواض
  Vectorادي لدينا منفرداً وفي صورةوبالتالي يكون كل و  Valueالخلية ھل القيمه أم العدد والصحيح أن نختار القيمة

 .وبالتالي يمكننا معرفة مساحة ومحيط الحوض بصورة بسيطة
 

Arc Toolbox > Conversion Tools > From Raster > Raster to Polygon 
  Input rasterفي  Basinندخل الملف الناتج عن

  Fieldفي  Valueنحدد
  put polygon featuresOutنحدد مسار ونكتب اسم ناتج العملية في

 
 :الوصول للبيانات اللازمة لانجاز معادلات التحليل المورفومتري -٩
 

يجب أن نعلم أن البرنامج يعتبر نقط الالتفاء فواصل بين الروافد بمعني وجود نقطة التقاء يقوم بتجزئة الرافد في حين 
تغيرت رتبته إلى رتبة أعلي فقط ولكن البرنامج كما ذكرنا يجعل  أنه طالما أن الرافد لا يتجزأ وإن مر به نقطة التقاء إلا إذا

لھذا الرافد الذي قطعه البرنامج إلى أجزاء منفصلة وذلك قبل البدء   Mergeمنفصلاً فيجب عمل دمج  Segmentكل جزء
أكد من وذلك للت  Must Not Have Pausedواستخدام القاعدة  Topologyفي استخلاص أي بيانات ويجب أيضاً عمل
 .أننا استكملنا عملية الدمج لكل الروافد

 
في قياس أقصي   Measurementلدينا من الخطوة السابقة مساحة الحوض ومحيطه، ويمكن استخدام أدوات القياس

 .عرض وطول للوادي
 

ما له، ك  Export dataعلى كل روافد الوادي ثم عمل  Selectionيجب فصل كل وادي على حدة وذلك بعمل اختيار
  .في استخلاص بيانات كل رتبة على حدة  Statisticsنقوم بالتعامل مع كل رتبة بصورة منفردة ونستخدم الامر
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